Synovia Solutions Status
Please enter your account number above to check your status.
Time And Attendance export and reporting maintenance
Incident Report for Synovia Solutions LLC
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 09:51 EST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2020 - 09:51 EST
Investigating
Emergency maintenance scheduled for 9:30 to fix reporting
Posted Nov 19, 2020 - 09:08 EST
This incident affected: Time and Attendance, Time and Attendance Portal, and Time and Attendance Reports.